
<!doctype html>
<html class="no-js" lang="en-US" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb#" >
    <head>

        <meta charset="UTF-8" />
        <meta name="viewport" content="width=device-width, initial-scale=1.0" />
        <meta http-equiv="cache-control" content="no-cache" />
        <meta name="gpsid" content="11438783" />
        <link rel="icon" href="https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/themes/BlackPress/assets/images/icons/favicon.ico" type="image/x-icon">
        <link rel="apple-touch-icon" sizes="144x144" href="https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/themes/BlackPress/assets/images/icons/apple-touch-icon-144x144.png">
        <link rel="apple-touch-icon" sizes="114x114" href="https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/themes/BlackPress/assets/images/icons/apple-touch-icon-114x114.png">
        <link rel="apple-touch-icon" sizes="72x72" href="https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/themes/BlackPress/assets/images/icons/apple-touch-icon-72x72.png">
        <link rel="apple-touch-icon" href="https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/themes/BlackPress/assets/images/icons/apple-touch-icon.png">
        <title>Police seek information on fatal 2017 crash in Abbotsford - Peace Arch News</title>
<!--
<PageMap>
	<DataObject type="thumbnail">
		<Attribute name="src" value="https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11438783_web1_whatcom-fatal-crash-300x200.jpg"/>
		<Attribute name="width" value="300"/>
		<Attribute name="height" value="200"/>
	</DataObject>
</PageMap>
-->
<!-- This site is optimized with the Yoast SEO plugin v5.9.1 - https://yoast.com/wordpress/plugins/seo/ -->
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Police seek information on fatal 2017 crash in Abbotsford - Peace Arch News" />
<meta property="og:description" content="Police say first responders saw on-lookers recording video at scene of deadly crash" />
<meta property="og:url" content="https://www.peacearchnews.com/news/police-seek-information-on-fatal-2017-crash-in-abbotsford/" />
<meta property="og:site_name" content="Peace Arch News" />
<meta property="article:section" content="News" />
<meta property="article:published_time" content="2018-04-13T08:00:00-07:00" />
<meta property="fb:app_id" content="307451845947866" />
<meta property="og:image" content="https://www.peacearchnews.com/wp-content/uploads/2018/04/11438783_web1_whatcom-fatal-crash.jpg" />
<meta property="og:image:secure_url" content="https://www.peacearchnews.com/wp-content/uploads/2018/04/11438783_web1_whatcom-fatal-crash.jpg" />
<meta property="og:image:width" content="1000" />
<meta property="og:image:height" content="667" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="
				Police say first responders saw on-lookers recording video at scene of deadly crash 
			" />
<meta name="twitter:title" content="Police seek information on fatal 2017 crash in Abbotsford - Peace Arch News" />
<meta name="twitter:image" content="https://www.peacearchnews.com/wp-content/uploads/2018/04/11438783_web1_whatcom-fatal-crash.jpg" />
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//ajax.googleapis.com' />
<link rel='dns-prefetch' href='//content.jwplatform.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='stylesheet' id='main-stylesheet-css'  href='https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/themes/BlackPress/dest/css/foundation.min.css?ver=2.20.0' type='text/css' media='all' />
<link rel='stylesheet' id='featherlight-css'  href='https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/themes/BlackPress/assets/components/featherlight/featherlight.css?ver=1.6.1' type='text/css' media='all' />
<script type='text/javascript' src='https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/plugins/wp-retina-2x/js/picturefill.min.js?ver=3.0.2'></script>
<script type='text/javascript' src='//ajax.googleapis.com/ajax/libs/jquery/2.1.0/jquery.min.js?ver=2.1.0'></script>
<link rel='https://api.w.org/' href='https://www.peacearchnews.com/wp-json/' />
<link rel="alternate" type="application/json+oembed" href="https://www.peacearchnews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.peacearchnews.com%2Fnews%2Fpolice-seek-information-on-fatal-2017-crash-in-abbotsford%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.peacearchnews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.peacearchnews.com%2Fnews%2Fpolice-seek-information-on-fatal-2017-crash-in-abbotsford%2F&#038;format=xml" />
<style type='text/css'>
.ai-viewport-3                { display: none !important;}
.ai-viewport-2                { display: none !important;}
.ai-viewport-1                { display: inherit !important;}
.ai-viewport-0                { display: none !important;}
@media (min-width: 768px) and (max-width: 979px) {
.ai-viewport-1                { display: none !important;}
.ai-viewport-2                { display: inherit !important;}
}
@media (max-width: 767px) {
.ai-viewport-1                { display: none !important;}
.ai-viewport-3                { display: inherit !important;}
}
</style>
<!-- DoubleClick for Publishers -->
<script type='text/javascript'>
 var googletag = googletag || {};
 googletag.cmd = googletag.cmd || [];
 (function() {
   var gads = document.createElement('script');
   gads.async = true;
   gads.type = 'text/javascript';
   var useSSL = 'https:' == document.location.protocol;
   gads.src = (useSSL ? 'https:' : 'http:') +
     '//www.googletagservices.com/tag/js/gpt.js';
   var node = document.getElementsByTagName('script')[0];
   node.parentNode.insertBefore(gads, node);
 })();
</script>

<script type='text/javascript'>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</script>
<!-- End DoubleClick for Publishers -->
<!-- 
    * Script creates the global generalSettings js array. 
    * Key/Value pair of Black Press general settings section: option name, option value 
    * NOTE: new options should be added to this array 
-->
<script type='text/javascript'>
        var generalSettings = {"postal_code":"V3Z 0C8","pub_code":"PAN","secondstreet_contest_feed":"http:\/\/peacearchnews.upickem.net\/Engine\/XMLFeed.aspx?AffiliateID=PANS"};

</script>

<!-- Start Google Analytics Tags -->
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
	ga('create', 'UA-17101303-15', 'auto', 't0');
	ga('t0.require', 'displayfeatures');
	ga('create', 'UA-17099191-2', 'auto', 't1');
	ga('t1.require', 'displayfeatures');
	ga('create', 'UA-17099191-1', 'auto', 't2');
	ga('t2.require', 'displayfeatures');
	ga('create', 'UA-17099191-9', 'auto', 't3');
	ga('t3.require', 'displayfeatures');
var jsonObj = JSON.parse('{"hitType":"pageview","dimension1":"Abbotsford News Staff","dimension2":"home2,news","dimension3":"untagged","dimension4":"post"}');
evtTrackMultiSend(jsonObj);

function evtTrackMultiSend(jsonObj) {
	ga(function() {
  		var trackers = ga.getAll();
  		trackers.forEach(function(tracker) {
  			ga(tracker.get('name')+'.send', jsonObj);
    			console.log(tracker.get('name') + " send ", jsonObj);
  		});
	});
}
//evtTrackMultiSend({ hitType: 'event', eventCategory: 'Recirculating Content', eventAction: 'click', eventLabel: 'next-adjacent-story'});
</script>    </head>
    <body class="post-template-default single single-post postid-86136 single-format-standard offcanvas">
        <!-- BEGIN: FACE BOOK COMMENTS PLUGIN CODE -->
        <div id="fb-root"></div>
        <script>(function(d, s, id) {
          var js, fjs = d.getElementsByTagName(s)[0];
          if (d.getElementById(id)) return;
          js = d.createElement(s); js.id = id;
          js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.8";
          fjs.parentNode.insertBefore(js, fjs);
        }(document, 'script', 'facebook-jssdk'));</script>
        <!-- END: FACE BOOK COMMENTS PLUGIN CODE -->

    
    
    
    <header id="masthead" class="site-header row collapse" role="banner">
        <!-- original divs replaced by code after. Note still have 2 divs, 
             with different settings for mobile and desktop -->
        <!-- <div  class="small-12 columns" data-sticky-container > -->
        <!-- <div id="sticky-menu-bar-container" class="top-bar title-bar row collapse" data-sticky data-options="marginTop:0;" style="width:100%"> -->
        <div  class="small-12 columns" data-sticky-container ><div id="sticky-menu-bar-container" class="top-bar title-bar row collapse" data-sticky data-options="marginTop:0;" style="width:100%">            
            
            <article id="text-1" class="menu-button-container small-1 medium-1 columns">
                    <div id="mobile-menu-button" data-responsive-toggle="site-navigation" data-hide-for="medium">
                        <button class="fa fa-bars menu" type="button" data-toggle="site-navigation"></button>
                    </div>
                    <ul id="menu-mainmenu" class="dropdown menu day-6 show-for-medium" data-dropdown-menu data-options="hoverDelay:150;"><li><a href="#"><i class="fa fa-bars menu"></i></a><ul class="dropdown menu" data-dropdown-menu><li class='nav-search'><a href='/search/'><i class='fa fa-search menu'></i>Search</a></li><li id="menu-item-320" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-320"><a href="https://www.peacearchnews.com/">Home</a></li>
<li id="menu-item-67577" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-67577"><a href="https://www.peacearchnews.com/submit/">Submit News Tip</a></li>
<li id="menu-item-169" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-169"><a href="https://www.peacearchnews.com/./news/">News</a>
<ul class="dropdown menu vertical" data-toggle>
	<li id="menu-item-170" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-170"><a href="https://www.peacearchnews.com/./local-news/">Local</a></li>
	<li id="menu-item-171" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-171"><a target="_blank" href="http://bclocalnews.com">BC</a></li>
	<li id="menu-item-172" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-172"><a href="https://www.peacearchnews.com/./national-news/">Canada &amp; World</a></li>
	<li id="menu-item-173" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-173"><a href="https://www.peacearchnews.com/e-editions/">eEditions</a></li>
	<li id="menu-item-176" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-176"><a href="https://www.peacearchnews.com/submit/">Submit news tip or photo</a></li>
</ul>
</li>
<li id="menu-item-177" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-177"><a href="https://www.peacearchnews.com/./sports/">Sports</a>
<ul class="dropdown menu vertical" data-toggle>
	<li id="menu-item-178" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-178"><a href="https://www.peacearchnews.com/./local-sports/">Local</a></li>
	<li id="menu-item-348" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-348"><a href="https://www.peacearchnews.com/tag/surrey-eagles/">Surrey Eagles</a></li>
	<li id="menu-item-347" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-347"><a href="https://www.peacearchnews.com/tag/bchl/">BCHL</a></li>
	<li id="menu-item-349" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-349"><a href="https://www.peacearchnews.com/tag/valley-west-hawks/">Valley West Hawks</a></li>
	<li id="menu-item-345" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-345"><a href="https://www.peacearchnews.com/tag/bcmml/">BC Major Midget League</a></li>
	<li id="menu-item-350" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-350"><a href="https://www.peacearchnews.com/tag/white-rock-tritons/">White Rock Tritons</a></li>
	<li id="menu-item-346" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-346"><a href="https://www.peacearchnews.com/tag/bcpbl/">BC Premier Baseball League</a></li>
	<li id="menu-item-322" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-322"><a target="_blank" href="http://www.bclocalnews.com/sports/">BC</a></li>
	<li id="menu-item-179" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-179"><a href="https://www.peacearchnews.com/./national-sports/">Canada &amp; World</a></li>
	<li id="menu-item-180" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-180"><a href="https://www.peacearchnews.com/submit/">Submit sports tip or photo</a></li>
</ul>
</li>
<li id="menu-item-181" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-181"><a href="https://www.peacearchnews.com/./trending-now/">Trending Now</a></li>
<li id="menu-item-182" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-182"><a href="https://www.peacearchnews.com/./business/">Business</a>
<ul class="dropdown menu vertical" data-toggle>
	<li id="menu-item-183" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-183"><a href="https://www.peacearchnews.com/./local-business/">Local</a></li>
	<li id="menu-item-184" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-184"><a target="_blank" href="http://bclocalnews.com/business">BC</a></li>
	<li id="menu-item-185" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-185"><a href="https://www.peacearchnews.com/submit/">Submit business tip or photo</a></li>
</ul>
</li>
<li id="menu-item-186" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-186"><a href="https://www.peacearchnews.com/./entertainment/">Entertainment</a>
<ul class="dropdown menu vertical" data-toggle>
	<li id="menu-item-187" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-187"><a href="https://www.peacearchnews.com/./local-entertainment/">Local</a></li>
	<li id="menu-item-188" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-188"><a target="_blank" href="http://bclocalnews.com/entertainment">BC</a></li>
	<li id="menu-item-189" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-189"><a href="https://www.peacearchnews.com/submit/">Submit entertainment tip or photo</a></li>
</ul>
</li>
<li id="menu-item-190" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-190"><a href="https://www.peacearchnews.com/./life/">Life</a>
<ul class="dropdown menu vertical" data-toggle>
	<li id="menu-item-191" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-191"><a href="https://www.peacearchnews.com/./life/">Local</a></li>
	<li id="menu-item-192" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-192"><a target="_blank" href="http://bclocalnews.com/life">BC</a></li>
	<li id="menu-item-193" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-193"><a target="_blank" href="http://winetrails.ca">Wine Trails</a></li>
	<li id="menu-item-194" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-194"><a href="https://www.peacearchnews.com/submit/">Submit life tip or photo</a></li>
</ul>
</li>
<li id="menu-item-195" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-195"><a href="https://www.peacearchnews.com/./community/">Community</a>
<ul class="dropdown menu vertical" data-toggle>
	<li id="menu-item-196" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-196"><a href="https://www.peacearchnews.com/./community/">Local</a></li>
	<li id="menu-item-351" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-351"><a href="/e-editions/?iid=i20160608161324549&#038;pid=p20120309121148491">Discover the Peninsula</a></li>
	<li id="menu-item-323" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-323"><a target="_blank" href="https://www.facebook.com/iLoveBritishColumbia">I Love British Columbia</a></li>
	<li id="menu-item-197" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-197"><a href="https://www.peacearchnews.com/calendar/">Calendar</a></li>
	<li id="menu-item-198" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-198"><a href="https://www.peacearchnews.com/submit/">Submit community tip or photo</a></li>
</ul>
</li>
<li id="menu-item-282" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-282"><a href="https://www.peacearchnews.com/./opinion/">Opinion</a>
<ul class="dropdown menu vertical" data-toggle>
	<li id="menu-item-204" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-204"><a href="https://www.peacearchnews.com/./opinion/">Local Opinion</a></li>
	<li id="menu-item-202" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-202"><a href="https://www.peacearchnews.com/./editorials-opinion/">Editorials</a></li>
	<li id="menu-item-201" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-201"><a href="https://www.peacearchnews.com/./columns/">Columnists</a></li>
	<li id="menu-item-203" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-203"><a href="https://www.peacearchnews.com/./letters/">Letters</a></li>
	<li id="menu-item-66233" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-66233"><a href="https://www.peacearchnews.com/./web-poll/">Web poll</a></li>
	<li id="menu-item-205" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-205"><a target="_blank" href="http://bclocalnews.com/opinion">BC Opinion</a></li>
	<li id="menu-item-206" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-206"><a href="https://www.peacearchnews.com/submitletters/">Submit letter</a></li>
	<li id="menu-item-66232" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-66232"><a href="https://www.peacearchnews.com/./web-poll/">Web poll</a></li>
</ul>
</li>
<li id="menu-item-210" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-210"><a href="https://www.peacearchnews.com/videos/">Videos</a>
<ul class="dropdown menu vertical" data-toggle>
	<li id="menu-item-211" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-211"><a href="https://www.peacearchnews.com/videos/">Local</a></li>
	<li id="menu-item-212" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-212"><a href="https://www.peacearchnews.com/submit/">Submit video</a></li>
	<li id="menu-item-213" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-213"><a target="_blank" href="http://blackpress.tv">Black Press TV</a></li>
</ul>
</li>
<li id="menu-item-214" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-214"><a href="https://www.peacearchnews.com/weather/">Weather</a></li>
<li id="menu-item-216" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-216"><a href="https://www.peacearchnews.com/./obituaries/">Obituaries</a></li>
<li id="menu-item-217" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-217"><a href="https://www.peacearchnews.com/./marketplace/">Marketplace</a>
<ul class="dropdown menu vertical" data-toggle>
	<li id="menu-item-275" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-275"><a href="https://www.peacearchnews.com/advertise/">Place an ad</a></li>
	<li id="menu-item-218" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-218"><a href="https://www.peacearchnews.com/./marketplace/">Impress branded content</a></li>
	<li id="menu-item-44609" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-44609"><a href="https://www.peacearchnews.com/real-estate/">Real Estate</a></li>
	<li id="menu-item-222" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-222"><a target="_blank" href="http://blackpress4good.com">Crowdfunding</a></li>
</ul>
</li>
<li id="menu-item-321" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-321"><a href="https://www.peacearchnews.com/contests/">Contests</a></li>
<li id="menu-item-224" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-224"><a href="https://www.peacearchnews.com/contact-us/">Contact Us</a>
<ul class="dropdown menu vertical" data-toggle>
	<li id="menu-item-225" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-225"><a href="https://www.peacearchnews.com/contact-us/">Contact Us</a></li>
	<li id="menu-item-226" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-226"><a href="https://www.peacearchnews.com/our-team/">Our Team</a></li>
	<li id="menu-item-230" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-230"><a target="_blank" href="http://blackpress.ca">Black Press</a></li>
	<li id="menu-item-231" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-231"><a href="https://www.peacearchnews.com/submit/">Submit tip or photo</a></li>
	<li id="menu-item-227" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-227"><a href="https://www.peacearchnews.com/faq/">FAQ</a></li>
	<li id="menu-item-228" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-228"><a href="https://www.peacearchnews.com/privacy-policy/">Privacy Policy</a></li>
	<li id="menu-item-229" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-229"><a href="https://www.peacearchnews.com/terms-of-use/">Terms of use</a></li>
</ul>
</li>
</ul></li></ul>
                </article>
                <article id="text-2" class="small-10 medium-10 columns">
                    <ul data-test="test" id="menu-secondarymenu" class="dropdown menu" data-dropdown-menu>
                                    <li id="menu-item-249" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-249"><a href="https://www.peacearchnews.com/./news/">NEWS</a>
<ul class="vertical nested menu">
	<li id="menu-item-250" class="show-for-medium menu-item menu-item-type-taxonomy menu-item-object-category menu-item-250"><a href="https://www.peacearchnews.com/./local-news/">Local News</a></li>
	<li id="menu-item-256" class="show-for-medium menu-item menu-item-type-custom menu-item-object-custom menu-item-256"><a target="_blank" href="http://bclocalnews.com">BC</a></li>
	<li id="menu-item-251" class="show-for-medium menu-item menu-item-type-taxonomy menu-item-object-category menu-item-251"><a href="https://www.peacearchnews.com/./national-news/">Canada &amp; World</a></li>
	<li id="menu-item-252" class="show-for-medium menu-item menu-item-type-post_type menu-item-object-page menu-item-252"><a href="https://www.peacearchnews.com/e-editions/">eEditions</a></li>
</ul>
</li>
<li id="menu-item-317" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-317"><a href="https://www.peacearchnews.com/./video/">VIDEO</a></li>
<li id="menu-item-260" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-260"><a target="_blank" href="http://www.bcclassifieds.com/">CLASSIFIEDS</a></li>
<li id="menu-item-258" class="show-for-medium menu-item menu-item-type-taxonomy menu-item-object-category menu-item-258"><a href="https://www.peacearchnews.com/./obituaries/">OBITUARIES</a></li>
<li id="menu-item-280" class="show-for-medium e-editions menu-item menu-item-type-post_type menu-item-object-page menu-item-280"><a href="https://www.peacearchnews.com/e-editions/">E-EDITIONS</a></li>
<li id="menu-item-318" class="show-for-medium menu-item menu-item-type-custom menu-item-object-custom menu-item-318"><a target="_blank" href="http://localworkbc.com">JOBS</a></li>
<li id="menu-item-337" class="show-for-large menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-337"><a href="https://www.peacearchnews.com/contact-us/">CONTACT</a>
<ul class="vertical nested menu">
	<li id="menu-item-269" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-269"><a href="https://www.peacearchnews.com/contact-us/">Contact Us</a></li>
	<li id="menu-item-64899" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-64899"><a href="https://www.peacearchnews.com/our-team/">Our Team</a></li>
	<li id="menu-item-270" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-270"><a href="https://www.peacearchnews.com/submit/">Submit news tip or photo</a></li>
</ul>
</li>
<li id="menu-item-336" class="show-for-large menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-336"><a href="https://www.peacearchnews.com/./marketplace/">MARKETPLACE</a>
<ul class="vertical nested menu">
	<li id="menu-item-274" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-274"><a href="https://www.peacearchnews.com/advertise/">Place an ad</a></li>
	<li id="menu-item-262" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-262"><a href="https://www.peacearchnews.com/./marketplace/">Impress</a></li>
	<li id="menu-item-44616" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-44616"><a href="https://www.peacearchnews.com/real-estate/">Real Estate</a></li>
	<li id="menu-item-266" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-266"><a target="_blank" href="http://blackpress4good.com">Crowdfunding</a></li>
</ul>
</li>
<li id="menu-item-319" class="show-for-large menu-item menu-item-type-post_type menu-item-object-page menu-item-319"><a href="https://www.peacearchnews.com/contests/">CONTESTS</a></li>
<li id="nav-submit-button" >
                                    <span data-tooltip aria-haspopup="true" data-disable-hover="false" tabindex="1" title="Submit News Tips">
                                    <a href="https://www.peacearchnews.com/submit">
                                    <img src="https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/themes/BlackPress/assets/images/submit.png" id="header-submit-button">
                                    </a>
                                    </span>    
                                </li></ul>                </article>

                <!-- Search -->
                <article id="text-5" class="small-1 medium-1 columns">
                    
                        <button id="btn_search" type="button" class="float-right fa fa-search menu"></button>

                </article>

                <!-- Search -->
                <article id="div_search" class="small-12 columns">
                <!-- **************** -->
                <!-- Search form container -->
                    
                                        <form name="searchForm" action="/search/">
  
                        <div class="row collapse">
                            <div class="small-12 columns">

                                <div class="row collapse">
                                    <div class="small-2 medium-3 columns">
                                        &nbsp;
                                      <input name="cx" value="015619971846971042401:ufh1ywe-cms" type="hidden">
                                    </div>

                                    <div class="small-1 medium-3 columns">
                                        &nbsp;
                                      <input name="ie" value="UTF-8" type="hidden">
                                    </div>

                                    <div class="small-6 medium-4 columns">
                                        <input id="google_search_field" class="google-search-field" name="q" value="Story Search" style="" type="text">
                                      
                                    </div>

                                    <div class="small-3 medium-2 columns">
                                      
                                        <input class="google-search-button" value="Search" type="submit">

                                    </div>

                                </div>

                            </div>

                        </div>
                          
                    </form>
                 
                <!-- **************** -->
                </article>
                
                <article class="small-12 medium-12 columns">
                    <div class="line"></div>
                </article>
            
            </div>

        </div>
        
        <div class ="row" id="header-second-row">
            <article id="text-12" class="show-for-medium medium-3 columns widget widget_text">			<div class="textwidget"><ul class="social header">
	<!-- <li><a title="Weather" class="social fa fa-cloud" href="/weather/"></a></li> -->
	<li><a title="Follow us on Facebook" class="social fa fa-facebook-f" href="https://www.facebook.com/peacearchnews" target="_blank"></a></li>
	<li><a title="Follow us on Twitter" class="social fa fa-twitter" href="https://twitter.com/PeaceArchNews" target="_blank"></a></li>
	<!-- <li><a title="Follow us on Instagram" class="social fa fa-instagram" href="#"  target="_blank"></a></li> -->
</ul></div>
		</article>            <article id="text-11" class="small-8 medium-6 columns widget widget_text">			<div class="textwidget"><a class="pub-logo-large day-6" href="https://www.peacearchnews.com/"><svg id="Outline" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 409.98 51.81"><defs><style>.cls-1{fill:#231f20;}</style></defs><title></title><path class="bp-pub-logo" d="M52.16,2h9.1C71.56,2,76.95,6.12,76.95,16.91c0,9-3.5,15-12,15H61.27v20h-9.1Zm9.17,22.61h.77c3.71,0,5.74-1.47,5.74-7.49C67.85,9.9,65,9.69,62,9.69h-.7Z" transform="translate(-52.16 -1.01)"/><path class="bp-pub-logo" d="M80.79,2h20.58v7.7H89.89V22.44h8.47v8.12H89.89V44.14h12v7.7H80.79Z" transform="translate(-52.16 -1.01)"/><path class="bp-pub-logo" d="M111.31,2h13.16l6.16,49.85h-8.75l-1.33-11.06H113.2l-1.26,11.06h-7.63Zm5.81,7.7H117l-2.87,23.8h5.67Z" transform="translate(-52.16 -1.01)"/><path class="bp-pub-logo" d="M150.65,20.06c0-8.26-1.05-11.34-3.29-11.34-1.89,0-3.78,1.26-3.78,18.2,0,16.38,1,18.2,3.78,18.2,3,0,3.71-4.62,3.85-11.83l7.7.35c0,8.68-1.26,19.18-11.9,19.18-9.73,0-13-9.52-13-25.9,0-19,5.74-25.9,13-25.9,10.5,0,11.76,9.66,11.76,18.76Z" transform="translate(-52.16 -1.01)"/><path class="bp-pub-logo" d="M165.28,2h20.58v7.7H174.38V22.44h8.47v8.12h-8.47V44.14h12v7.7H165.28Z" transform="translate(-52.16 -1.01)"/><path class="bp-pub-logo" d="M210.78,2h13.16l6.16,49.85h-8.75L220,40.78h-7.35l-1.26,11.06h-7.63Zm5.81,7.7h-.14l-2.87,23.8h5.67Z" transform="translate(-52.16 -1.01)"/><path class="bp-pub-logo" d="M234.86,2h10.22c8.68,0,14.42,3.64,14.42,14.14,0,4.2-1.26,9.8-5.32,12.18l5.39,23.52H250.4l-4.27-21.42H244V51.84h-9.1ZM244,23.14h1.82c3.36,0,4.62-3.36,4.62-6.93,0-5.39-2-6.93-5-6.93H244Z" transform="translate(-52.16 -1.01)"/><path class="bp-pub-logo" d="M280,20.06c0-8.26-1.05-11.34-3.29-11.34-1.89,0-3.78,1.26-3.78,18.2,0,16.38,1,18.2,3.78,18.2,3,0,3.71-4.62,3.85-11.83l7.7.35c0,8.68-1.26,19.18-11.9,19.18-9.73,0-13-9.52-13-25.9,0-19,5.74-25.9,13-25.9,10.5,0,11.76,9.66,11.76,18.76Z" transform="translate(-52.16 -1.01)"/><path class="bp-pub-logo" d="M294.64,2h9.1V22h5.74V2h9.1V51.84h-9.1V30.7h-5.74V51.84h-9.1Z" transform="translate(-52.16 -1.01)"/><path class="bp-pub-logo" d="M340.49,2h8.89l8.33,26.32h.14V2h7.28V51.84h-7.07l-9.73-30.17h-.14V51.84h-7.7Z" transform="translate(-52.16 -1.01)"/><path class="bp-pub-logo" d="M372.06,2h20.58v7.7H381.16V22.44h8.47v8.12h-8.47V44.14h12v7.7H372.06Z" transform="translate(-52.16 -1.01)"/><path class="bp-pub-logo" d="M396.84,2h8.26l3.22,29.26h.14L412.8,2H421l4,29.26h.14L428.69,2h6.51l-6.51,49.85h-8.26l-4.34-31.57h-.14l-4.48,31.57h-8Z" transform="translate(-52.16 -1.01)"/><path class="bp-pub-logo" d="M446,37.42c0,2.8,0,7.7,3.92,7.7,3,0,4.06-2.8,4.06-4.83,0-8.89-16.52-10.92-16.52-25.69C437.51,7.1,441.57,1,449.27,1c8.19,0,11.34,6.23,11.55,15.19H452.7c0-2.8,0-7.49-3.64-7.49-2.17,0-3.43,1.82-3.43,4.55,0,8.47,16.52,11.34,16.52,25.83,0,7.63-4.34,13.72-12.53,13.72-9.73,0-11.69-8.54-11.69-15.4Z" transform="translate(-52.16 -1.01)"/></svg></a></div>
		</article>            
            

                            <article id="text-33" class="small-4 medium-3 columns">
                    <div id="weatherContainer" class="textwidget float-right" >
                        
                        <a href="https://www.accuweather.com/en/ca/surrey/v3r/weather-forecast/47171" 
                                        class="aw-widget-legal">
                                        </a><div id="awcc1517357785678" class="aw-widget-current"  data-locationkey="47171" data-unit="c" data-language="en-us" data-useip="false" data-uid="awcc1517357785678" data-targeturl="/weather/"></div><script type="text/javascript" src="https://oap.accuweather.com/launch.js"></script>                        
                    </div>
                </article>
                        
        </div>
        
        <!-- Mobile menu -->
        <nav id="site-navigation" class="main-navigation top-bar" role="navigation">
            <div class="top-bar-right row">
                                    
<nav class="vertical menu" id="mobile-menu" role="navigation">
    <ul id="menu-mainmenu-1" class="vertical menu accordion menu" data-accordion-menu><li class='nav-search'><a href='/search/'><i class='fa fa-search menu'></i>Search</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-320"><a href="https://www.peacearchnews.com/">Home</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-67577"><a href="https://www.peacearchnews.com/submit/">Submit News Tip</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-169"><a href="https://www.peacearchnews.com/./news/">News</a>
<ul class="vertical nested menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-170"><a href="https://www.peacearchnews.com/./local-news/">Local</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-171"><a target="_blank" href="http://bclocalnews.com">BC</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-172"><a href="https://www.peacearchnews.com/./national-news/">Canada &amp; World</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-173"><a href="https://www.peacearchnews.com/e-editions/">eEditions</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-176"><a href="https://www.peacearchnews.com/submit/">Submit news tip or photo</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-177"><a href="https://www.peacearchnews.com/./sports/">Sports</a>
<ul class="vertical nested menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-178"><a href="https://www.peacearchnews.com/./local-sports/">Local</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-348"><a href="https://www.peacearchnews.com/tag/surrey-eagles/">Surrey Eagles</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-347"><a href="https://www.peacearchnews.com/tag/bchl/">BCHL</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-349"><a href="https://www.peacearchnews.com/tag/valley-west-hawks/">Valley West Hawks</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-345"><a href="https://www.peacearchnews.com/tag/bcmml/">BC Major Midget League</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-350"><a href="https://www.peacearchnews.com/tag/white-rock-tritons/">White Rock Tritons</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-346"><a href="https://www.peacearchnews.com/tag/bcpbl/">BC Premier Baseball League</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-322"><a target="_blank" href="http://www.bclocalnews.com/sports/">BC</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-179"><a href="https://www.peacearchnews.com/./national-sports/">Canada &amp; World</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-180"><a href="https://www.peacearchnews.com/submit/">Submit sports tip or photo</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-181"><a href="https://www.peacearchnews.com/./trending-now/">Trending Now</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-182"><a href="https://www.peacearchnews.com/./business/">Business</a>
<ul class="vertical nested menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-183"><a href="https://www.peacearchnews.com/./local-business/">Local</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-184"><a target="_blank" href="http://bclocalnews.com/business">BC</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-185"><a href="https://www.peacearchnews.com/submit/">Submit business tip or photo</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-186"><a href="https://www.peacearchnews.com/./entertainment/">Entertainment</a>
<ul class="vertical nested menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-187"><a href="https://www.peacearchnews.com/./local-entertainment/">Local</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-188"><a target="_blank" href="http://bclocalnews.com/entertainment">BC</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-189"><a href="https://www.peacearchnews.com/submit/">Submit entertainment tip or photo</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-190"><a href="https://www.peacearchnews.com/./life/">Life</a>
<ul class="vertical nested menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-191"><a href="https://www.peacearchnews.com/./life/">Local</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-192"><a target="_blank" href="http://bclocalnews.com/life">BC</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-193"><a target="_blank" href="http://winetrails.ca">Wine Trails</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-194"><a href="https://www.peacearchnews.com/submit/">Submit life tip or photo</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-195"><a href="https://www.peacearchnews.com/./community/">Community</a>
<ul class="vertical nested menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-196"><a href="https://www.peacearchnews.com/./community/">Local</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-351"><a href="/e-editions/?iid=i20160608161324549&#038;pid=p20120309121148491">Discover the Peninsula</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-323"><a target="_blank" href="https://www.facebook.com/iLoveBritishColumbia">I Love British Columbia</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-197"><a href="https://www.peacearchnews.com/calendar/">Calendar</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-198"><a href="https://www.peacearchnews.com/submit/">Submit community tip or photo</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-282"><a href="https://www.peacearchnews.com/./opinion/">Opinion</a>
<ul class="vertical nested menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-204"><a href="https://www.peacearchnews.com/./opinion/">Local Opinion</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-202"><a href="https://www.peacearchnews.com/./editorials-opinion/">Editorials</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-201"><a href="https://www.peacearchnews.com/./columns/">Columnists</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-203"><a href="https://www.peacearchnews.com/./letters/">Letters</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-66233"><a href="https://www.peacearchnews.com/./web-poll/">Web poll</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-205"><a target="_blank" href="http://bclocalnews.com/opinion">BC Opinion</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-206"><a href="https://www.peacearchnews.com/submitletters/">Submit letter</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-66232"><a href="https://www.peacearchnews.com/./web-poll/">Web poll</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-210"><a href="https://www.peacearchnews.com/videos/">Videos</a>
<ul class="vertical nested menu">
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-211"><a href="https://www.peacearchnews.com/videos/">Local</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-212"><a href="https://www.peacearchnews.com/submit/">Submit video</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-213"><a target="_blank" href="http://blackpress.tv">Black Press TV</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-214"><a href="https://www.peacearchnews.com/weather/">Weather</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-216"><a href="https://www.peacearchnews.com/./obituaries/">Obituaries</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-217"><a href="https://www.peacearchnews.com/./marketplace/">Marketplace</a>
<ul class="vertical nested menu">
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-275"><a href="https://www.peacearchnews.com/advertise/">Place an ad</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-218"><a href="https://www.peacearchnews.com/./marketplace/">Impress branded content</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-44609"><a href="https://www.peacearchnews.com/real-estate/">Real Estate</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-222"><a target="_blank" href="http://blackpress4good.com">Crowdfunding</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-321"><a href="https://www.peacearchnews.com/contests/">Contests</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-224"><a href="https://www.peacearchnews.com/contact-us/">Contact Us</a>
<ul class="vertical nested menu">
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-225"><a href="https://www.peacearchnews.com/contact-us/">Contact Us</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-226"><a href="https://www.peacearchnews.com/our-team/">Our Team</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-230"><a target="_blank" href="http://blackpress.ca">Black Press</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-231"><a href="https://www.peacearchnews.com/submit/">Submit tip or photo</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-227"><a href="https://www.peacearchnews.com/faq/">FAQ</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-228"><a href="https://www.peacearchnews.com/privacy-policy/">Privacy Policy</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-229"><a href="https://www.peacearchnews.com/terms-of-use/">Terms of use</a></li>
</ul>
</li>
</ul></nav>
                            </div>
        </nav>
        

    </header>

    <section class="container">
        <!-- Elevator: return to Top -->
        <a id="return-to-top" href="javascript:" ><i class="fa fa-chevron-up"></i></a>
        
        

<div id="single-post" role="main">

    <div class="row module ad">
        <div class="large-12 columns ad text-center">
            <div class='code-block code-block-24' style='margin: 8px 0; clear: both;'>
<!-- Replace AU0 on article pages -->
<div id="div-gpt-24" class="gpt-ad horizontal">
<script type='text/javascript'>
    googletag.cmd.push(function() { googletag.display('div-gpt-24');gptRefreshSlots.push(24); });
</script>
</div></div>
        </div>
    </div>

    <!-- Number of attachments: 1 --><!-- Featured Image Layout: medium -->

                <article class="main-content post-86136 post type-post status-publish format-standard has-post-thumbnail hentry category-home2 category-news" id="post-86136">

        
        <header>
            <div class="post-attachment" alt="&lt;1024 - &gt;640"><img width="1000" height="667" src="https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11438783_web1_whatcom-fatal-crash.jpg" class="attachment-full size-full" alt="" srcset="https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11438783_web1_whatcom-fatal-crash.jpg 1000w, https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11438783_web1_whatcom-fatal-crash-300x200.jpg 300w, https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11438783_web1_whatcom-fatal-crash-640x427.jpg 640w, https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11438783_web1_whatcom-fatal-crash-300x200@2x.jpg 600w" sizes="(max-width: 1199px) 98vw, 1000px" /><p></p></div>
                                    <h2 class="entry-title">Police seek information on fatal 2017 crash in Abbotsford</h2>
            <p class="lead">Police say first responders saw on-lookers recording video at scene of deadly crash
</p>
            <ul class="author-meta"><li><a class="byline" href="https://www.peacearchnews.com/author/abb-staff/" rel="author" class="fn">Abbotsford News Staff</a></li><li>Apr. 13, 2018 8:00 a.m.</li><li><a class="byline" href="https://www.peacearchnews.com/news/">News</a></li></ul>            <ul class="social story top">
	<li><span data-tooltip aria-haspopup="true" data-disable-hover="false" tabindex="1" title="Post to Facebook"><a href="//www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.peacearchnews.com%2Fnews%2Fpolice-seek-information-on-fatal-2017-crash-in-abbotsford%2F" class="social fa fa-facebook-f"></a></span></li>
	<li><span data-tooltip aria-haspopup="true" data-disable-hover="false" tabindex="1" title="Post to Twitter"><a href="//twitter.com/home?status=Police+seek+information+on+fatal+2017+crash+in+Abbotsford+-+https%3A%2F%2Fwww.peacearchnews.com%2Fnews%2Fpolice-seek-information-on-fatal-2017-crash-in-abbotsford%2F" class="social fa fa-twitter"></a></span></li>
	<li><span data-tooltip aria-haspopup="true" data-disable-hover="false" tabindex="1" title="Post to Reddit"><a href="//reddit.com/submit?url=https%3A%2F%2Fwww.peacearchnews.com%2Fnews%2Fpolice-seek-information-on-fatal-2017-crash-in-abbotsford%2F&title=Police+seek+information+on+fatal+2017+crash+in+Abbotsford" class="social fa fa-reddit-alien"></a></span></li>
	<li><span data-tooltip aria-haspopup="true" data-disable-hover="false" tabindex="1" title="Email story"><a href="mailto:?subject=Police%20seek%20information%20on%20fatal%202017%20crash%20in%20Abbotsford&ampsubject=Police%20seek%20information%20on%20fatal%202017%20crash%20in%20Abbotsford&amp;body=https%3A%2F%2Fwww.peacearchnews.com%2Fnews%2Fpolice-seek-information-on-fatal-2017-crash-in-abbotsford%2F" class="social fa fa-envelope-o"></a></span></li>
	<li><span data-tooltip aria-haspopup="true" data-disable-hover="false" tabindex="1" title="Print story"><a href="javascript:window.print();" class="social fa fa-print"></a></span></li>
	<li><span data-tooltip aria-haspopup="true" data-disable-hover="false" tabindex="1" title="Jump to comments"><a href="#facebook-comments" class="social fa fa-comment-o"></a></span></li>
</ul>
        </header>
                <div class="entry-content">

        <p>Abbotsford Police are renewing a call for information about a <a href="https://www.abbynews.com/news/one-man-dead-after-friday-vehicle-crash/" target="_blank">fatal crash last September</a>.</p>
<p>On Sept. 15, a 33-year-old man was killed the Chevrolet Cavalier he was driving south <a href="https://www.google.ca/maps/place/2400+Whatcom+Rd,+Abbotsford,+BC+V3G+1E1/@49.0454595,-122.2255017,17.24z/data=!4m5!3m4!1s0x54844a4013290491:0xa0f90af9eefbe36f!8m2!3d49.045773!4d-122.2240045" target="_blank">on Whatcom Road</a> collided head-on with a Dodge Charger being driven the opposite direction. The 21-year-old driver of the Dodge sustained non-life-threatening injuries in the collision.</p>
<p>Police issued another plea for information this week. They say first responders recalled seeing bystanders recording the collision site. Anyone who may have witnessed the crash, or may have knowledge or video pertaining to it, is asked to call police at 604-859-5225, text 222973 (abbypd), or call Crime Stoppers anonymously at 1-800-222-8477.</p>
                        </div>
        
        <!-- Start: Spot.IM setup -->
                <!-- End: Spot.IM setup -->

        <!-- BEGIN: Comments -->
                                <div class="fb-comments" id="facebook-comments" data-href="https://www.peacearchnews.com/news/police-seek-information-on-fatal-2017-crash-in-abbotsford/" data-width="100%" data-numposts="10" data-order-by="reverse_time" data-colorscheme="light"></div>
                <!-- END: Comments -->

        <footer>
                    </footer>
                
        <!-- Comments disabled for now -->
        <!-- <a class="hollow expanded button comments day-" href="">View Comments <i class="fa fa-comment-o"></i></a> -->
        
        
        <div class="row" style="padding-bottom: 1.5rem;"><div class="columns small-12 medium-12 large-6"><div class='code-block code-block-14' style='margin: 8px auto; text-align: center; clear: both;'>
<div id="div-gpt-14" class="gpt-ad">
<script type='text/javascript'>
    googletag.cmd.push(function() { googletag.display('div-gpt-14');gptRefreshSlots.push(14); });
</script>
</div></div>
</div><div class="columns small-12 medium-12 large-6"><div class='code-block code-block-19' style='margin: 8px auto; text-align: center; clear: both;'>
<div id="div-gpt-19" class="gpt-ad">
<script type='text/javascript'>
    googletag.cmd.push(function() { googletag.display('div-gpt-19');gptRefreshSlots.push(19); });
</script>
</div></div>
</div></div>        
    </article>


<aside class="sidebar text-right">
		<article id="ai_widget-6" class="widget ai_widget"><div class='code-block code-block-2' style='margin: 8px auto; text-align: center; clear: both;'>
<div id="div-gpt-2" class="gpt-ad">
<script type='text/javascript'>
    googletag.cmd.push(function() { googletag.display('div-gpt-2');gptRefreshSlots.push(2); });
</script>
</div></div>
</article><article id="ai_widget-10" class="widget ai_widget"><div class='code-block code-block-10' style='margin: 8px auto; text-align: center; clear: both;'>
<div id="div-gpt-10" class="gpt-ad">
<script type='text/javascript'>
    googletag.cmd.push(function() { googletag.display('div-gpt-10');gptRefreshSlots.push(10); });
</script>
</div></div>
</article><article id="ai_widget-8" class="widget ai_widget"><div class='code-block code-block-12' style='margin: 8px auto; text-align: center; clear: both;'>
<div id="div-gpt-12" class="gpt-ad">
<script type='text/javascript'>
    googletag.cmd.push(function() { googletag.display('div-gpt-12');gptRefreshSlots.push(12); });
</script>
</div></div>
</article>	</aside>
</div>

<div class="row module-adjacent-posts" data-equalizer data-equalize-on="medium">
	    <div class="small-6 adjacent-prev columns" data-equalizer-watch>
                    <a class="button" onClick="__gaTracker('send','event','Recirculating Content','Click','Previous Adjacent Story');" href="https://www.peacearchnews.com/news/b-c-mom-backs-mps-calls-for-criminal-probe-of-opioid-manufacturers/">
                <h5><i class="fa fa-chevron-left" aria-hidden="true"></i>Previous <span class="show-for-small-only">story </span></h5>
                <span class="show-for-medium">
                    <h6>B.C. mom backs MP&#8217;s calls for criminal probe of opioid manufacturers</h6>
                </span>
            </a>
            </div>
    <div class="small-6 adjacent-next columns" data-equalizer-watch>
                    <a class="button" onClick="__gaTracker('send','event','Recirculating Content','Click','Next Adjacent Story');" href="https://www.peacearchnews.com/news/delta-school-district-sees-no-staff-cuts-in-proposed-2018-2019-budget/">
                <h5>Next <span class="show-for-small-only">story </span><i class="fa fa-chevron-right" aria-hidden="true"></i></h5>
                <span class="show-for-medium">
                    <h6>Delta School District sees no staff cuts in proposed 2018/2019 budget</h6>
                </span>
            </a>
            </div>
</div><div class="row module-recirc">
	<div class="small-12 columns">
		<h3 class="text-center"><a onClick="__gaTracker('send','event','Recirculating Content','Click','News Header');" href="https://www.peacearchnews.com/./news/">Just Posted</a></h3>
                <div class="row module-recirc">
            <div class="small-12 large-8 module-recirc columns">
                <!-- Transient Content single-a81d70e6152de6769020082d811f7451 --><!-- story-recirc-block --><div class="small-up-2 medium-up-2 large-up-3"><!-- Start - Single Card --><div class="column"><div class='card '><a onClick="__gaTracker('send','event','Recirculating Content','Click',' Post Block');" class="image" href="https://www.peacearchnews.com/news/warning-issued-after-spike-of-overdoses-in-surrey/"><img src="https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11437712_web1_10257938_web1_180119-SNW-M-emergency-crews-responding-to-overdose-in-Surrey-1024x683.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" srcset="https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11437712_web1_10257938_web1_180119-SNW-M-emergency-crews-responding-to-overdose-in-Surrey-1024x683.jpg 1024w, https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11437712_web1_10257938_web1_180119-SNW-M-emergency-crews-responding-to-overdose-in-Surrey-1024x683-300x200.jpg 300w, https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11437712_web1_10257938_web1_180119-SNW-M-emergency-crews-responding-to-overdose-in-Surrey-1024x683-640x427.jpg 640w, https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11437712_web1_10257938_web1_180119-SNW-M-emergency-crews-responding-to-overdose-in-Surrey-1024x683-300x200@2x.jpg 600w" sizes="(max-width: 1199px) 98vw, 1024px" /></a> <div class="card-section"><a onClick="__gaTracker('send','event','Recirculating Content','Click',' Post Block');" class="image" href="https://www.peacearchnews.com/news/warning-issued-after-spike-of-overdoses-in-surrey/"><h5 class="active">Warning issued after spike of overdoses in Surrey</h5></a><p class="lead show-for-medium">Fraser Health has issued an alert after a ‘significant increase’ in overdoses since Wednesday
</p></div></div></div><!-- End - Single Card --><!-- Start - Single Card --><div class="column"><div class='card '><a onClick="__gaTracker('send','event','Recirculating Content','Click',' Post Block');" class="image" href="https://www.peacearchnews.com/news/federal-minister-honours-semiahmoo-youth-in-accessibility-initiative/"><img src="https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11435360_web1_XX20180412-PAN-M-accessibility-initiative.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" srcset="https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11435360_web1_XX20180412-PAN-M-accessibility-initiative.jpg 1200w, https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11435360_web1_XX20180412-PAN-M-accessibility-initiative-300x200.jpg 300w, https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11435360_web1_XX20180412-PAN-M-accessibility-initiative-1024x683.jpg 1024w, https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11435360_web1_XX20180412-PAN-M-accessibility-initiative-640x427.jpg 640w, https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11435360_web1_XX20180412-PAN-M-accessibility-initiative-300x200@2x.jpg 600w" sizes="(max-width: 1200px) 100vw, 1200px" /></a> <div class="card-section"><a onClick="__gaTracker('send','event','Recirculating Content','Click',' Post Block');" class="image" href="https://www.peacearchnews.com/news/federal-minister-honours-semiahmoo-youth-in-accessibility-initiative/"><h5 class="active">Federal minister honours Semiahmoo youth in accessibility initiative</h5></a><p class="lead show-for-medium">Kirsty Duncan visits White Rock and South Surrey to launch Canada-wide program
</p></div></div></div><!-- End - Single Card --><!-- Start - Single Card --><div class="column"><div class='card '><a onClick="__gaTracker('send','event','Recirculating Content','Click',' Post Block');" class="image" href="https://www.peacearchnews.com/news/delta-school-district-sees-no-staff-cuts-in-proposed-2018-2019-budget/"><img src="https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11363757_web1_180118-NDR-SciencePreview_1.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" srcset="https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11363757_web1_180118-NDR-SciencePreview_1-640x427@2x.jpg 1280w, https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11363757_web1_180118-NDR-SciencePreview_1-300x200.jpg 300w, https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11363757_web1_180118-NDR-SciencePreview_1-1024x682.jpg 1024w, https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11363757_web1_180118-NDR-SciencePreview_1-640x427.jpg 640w, https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11363757_web1_180118-NDR-SciencePreview_1-1200x800.jpg 1200w, https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11363757_web1_180118-NDR-SciencePreview_1-300x200@2x.jpg 600w" sizes="(max-width: 1199px) 98vw, 1200px" /></a> <div class="card-section"><a onClick="__gaTracker('send','event','Recirculating Content','Click',' Post Block');" class="image" href="https://www.peacearchnews.com/news/delta-school-district-sees-no-staff-cuts-in-proposed-2018-2019-budget/"><h5 class="active">Delta School District sees no staff cuts in proposed 2018/2019 budget</h5></a><p class="lead show-for-medium">The budget will actually include eight new teachers hired and $500,000 for inclusive education
</p></div></div></div><!-- End - Single Card --><!-- Start - Single Card --><div class="column"><div class='card '><a onClick="__gaTracker('send','event','Recirculating Content','Click',' Post Block');" class="image" href="https://www.peacearchnews.com/news/white-rock-woman-appeals-for-return-of-stolen-e-bike/"><img src="https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11421234_web1_170525-RDA-M-RCMP-car.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" srcset="https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11421234_web1_170525-RDA-M-RCMP-car.jpg 1200w, https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11421234_web1_170525-RDA-M-RCMP-car-300x200.jpg 300w, https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11421234_web1_170525-RDA-M-RCMP-car-1024x683.jpg 1024w, https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11421234_web1_170525-RDA-M-RCMP-car-640x427.jpg 640w, https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11421234_web1_170525-RDA-M-RCMP-car-300x200@2x.jpg 600w" sizes="(max-width: 1200px) 100vw, 1200px" /></a> <div class="card-section"><a onClick="__gaTracker('send','event','Recirculating Content','Click',' Post Block');" class="image" href="https://www.peacearchnews.com/news/white-rock-woman-appeals-for-return-of-stolen-e-bike/"><h5 class="active">White Rock woman appeals for return of stolen e-bike</h5></a><p class="lead show-for-medium">Police say crime always increases as the weather warms
</p></div></div></div><!-- End - Single Card --><!-- Start - Single Card --><div class="column"><div class='card '><a onClick="__gaTracker('send','event','Recirculating Content','Click',' Post Block');" class="image" href="https://www.peacearchnews.com/news/rcmp-on-scene-at-176-street-and-no-10-highway/"><img src="https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11433069_web1_180418-CLR-Hwy10PoliceIncident_2.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" srcset="https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11433069_web1_180418-CLR-Hwy10PoliceIncident_2.jpg 1200w, https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11433069_web1_180418-CLR-Hwy10PoliceIncident_2-300x200.jpg 300w, https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11433069_web1_180418-CLR-Hwy10PoliceIncident_2-1024x683.jpg 1024w, https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11433069_web1_180418-CLR-Hwy10PoliceIncident_2-640x427.jpg 640w, https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11433069_web1_180418-CLR-Hwy10PoliceIncident_2-300x200@2x.jpg 600w" sizes="(max-width: 1200px) 100vw, 1200px" /></a> <div class="card-section"><a onClick="__gaTracker('send','event','Recirculating Content','Click',' Post Block');" class="image" href="https://www.peacearchnews.com/news/rcmp-on-scene-at-176-street-and-no-10-highway/"><h5 class="active">UPDATE: Highway 10 incident cleared, truck and trailer towed</h5></a><p class="lead show-for-medium">Nearby worker says he saw gun seized by officers
</p></div></div></div><!-- End - Single Card --><!-- Start - Single Card --><div class="column"><div class='card '><a onClick="__gaTracker('send','event','Recirculating Content','Click',' Post Block');" class="image" href="https://www.peacearchnews.com/news/video-traffic-concerns-linger-after-surrey-oks-church-townhouse-development-again/"><img src="https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11429425_web1_180412-SUL-Panorama.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" srcset="https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11429425_web1_180412-SUL-Panorama.jpg 686w, https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11429425_web1_180412-SUL-Panorama-300x200.jpg 300w, https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11429425_web1_180412-SUL-Panorama-640x426.jpg 640w, https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11429425_web1_180412-SUL-Panorama-300x200@2x.jpg 600w" sizes="(max-width: 1199px) 98vw, 686px" /></a> <div class="card-section"><a onClick="__gaTracker('send','event','Recirculating Content','Click',' Post Block');" class="image" href="https://www.peacearchnews.com/news/video-traffic-concerns-linger-after-surrey-oks-church-townhouse-development-again/"><h5 class="active">VIDEO: Traffic concerns linger after Surrey OKs church, townhouse development again</h5></a><p class="lead show-for-medium">Surrey resident shows city council videos of dangerous road conditions along 148th Street
</p></div></div></div><!-- End - Single Card --><!-- Start - Single Card --><div class="column"><div class='card '><a onClick="__gaTracker('send','event','Recirculating Content','Click',' Post Block');" class="image" href="https://www.peacearchnews.com/news/b-c-groups-form-coalition-with-scrap-the-speculation-tax-campaign/"><img src="https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11438675_web1_180323-PNR-real-estate-sidney-generic-1.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" srcset="https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11438675_web1_180323-PNR-real-estate-sidney-generic-1.jpg 1400w, https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11438675_web1_180323-PNR-real-estate-sidney-generic-1-300x199.jpg 300w, https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11438675_web1_180323-PNR-real-estate-sidney-generic-1-1024x680.jpg 1024w, https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11438675_web1_180323-PNR-real-estate-sidney-generic-1-640x425.jpg 640w, https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11438675_web1_180323-PNR-real-estate-sidney-generic-1-1200x797.jpg 1200w, https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11438675_web1_180323-PNR-real-estate-sidney-generic-1-300x199@2x.jpg 600w, https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11438675_web1_180323-PNR-real-estate-sidney-generic-1-640x425@2x.jpg 1280w" sizes="(max-width: 1199px) 98vw, 1200px" /></a> <div class="card-section"><a onClick="__gaTracker('send','event','Recirculating Content','Click',' Post Block');" class="image" href="https://www.peacearchnews.com/news/b-c-groups-form-coalition-with-scrap-the-speculation-tax-campaign/"><h5 class="active">B.C. groups form coalition with &#8216;Scrap the Speculation Tax&#8217; campaign</h5></a><p class="lead show-for-medium">Concerned British Columbians launch campaign to Scrap the Speculation Tax
</p></div></div></div><!-- End - Single Card --><!-- Start - Single Card --><div class="column"><div class='card '><a onClick="__gaTracker('send','event','Recirculating Content','Click',' Post Block');" class="image" href="https://www.peacearchnews.com/trending-now/5-to-start-your-day-247/"><img src="https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11438090_web1_180413-BPD-M-Blood_Donors1C.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" srcset="https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11438090_web1_180413-BPD-M-Blood_Donors1C-1024x683@2x.jpg 2048w, https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11438090_web1_180413-BPD-M-Blood_Donors1C-300x200.jpg 300w, https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11438090_web1_180413-BPD-M-Blood_Donors1C-1024x683.jpg 1024w, https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11438090_web1_180413-BPD-M-Blood_Donors1C-640x427.jpg 640w, https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11438090_web1_180413-BPD-M-Blood_Donors1C-1200x800.jpg 1200w, https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11438090_web1_180413-BPD-M-Blood_Donors1C-300x200@2x.jpg 600w, https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11438090_web1_180413-BPD-M-Blood_Donors1C-640x427@2x.jpg 1280w" sizes="(max-width: 1199px) 98vw, 1200px" /></a> <div class="card-section"><a onClick="__gaTracker('send','event','Recirculating Content','Click',' Post Block');" class="image" href="https://www.peacearchnews.com/trending-now/5-to-start-your-day-247/"><h5 class="active">5 to start your day</h5></a><p class="lead show-for-medium">Maple Ridge Mounties investigate fatal crash, Surrey boy battling cancer needs blood donors and more
</p></div></div></div><!-- End - Single Card --><!-- Start - Single Card --><div class="column"><div class='card '><a onClick="__gaTracker('send','event','Recirculating Content','Click',' Post Block');" class="image" href="https://www.peacearchnews.com/news/b-c-based-airline-expands-route-network/"><img src="https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11438102_web1_171215-KCN-flir-air.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" srcset="https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11438102_web1_171215-KCN-flir-air.jpg 1200w, https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11438102_web1_171215-KCN-flir-air-300x200.jpg 300w, https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11438102_web1_171215-KCN-flir-air-1024x683.jpg 1024w, https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11438102_web1_171215-KCN-flir-air-640x427.jpg 640w, https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11438102_web1_171215-KCN-flir-air-300x200@2x.jpg 600w" sizes="(max-width: 1200px) 100vw, 1200px" /></a> <div class="card-section"><a onClick="__gaTracker('send','event','Recirculating Content','Click',' Post Block');" class="image" href="https://www.peacearchnews.com/news/b-c-based-airline-expands-route-network/"><h5 class="active">B.C.-based airline expands route network</h5></a><p class="lead show-for-medium">Flair Air announces more routes effective June 15
</p></div></div></div><!-- End - Single Card --><!-- Start - Single Card --><div class="column"><div class='card '><a onClick="__gaTracker('send','event','Recirculating Content','Click',' Post Block');" class="image" href="https://www.peacearchnews.com/trending-now/whos-afraid-of-friday-the-13th/"><img src="https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11428260_web1_180413-IFD-black-cat-Friday-13th.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" srcset="https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11428260_web1_180413-IFD-black-cat-Friday-13th.jpg 960w, https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11428260_web1_180413-IFD-black-cat-Friday-13th-300x198.jpg 300w, https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11428260_web1_180413-IFD-black-cat-Friday-13th-640x423.jpg 640w, https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11428260_web1_180413-IFD-black-cat-Friday-13th-300x198@2x.jpg 600w" sizes="(max-width: 1199px) 98vw, 960px" /></a> <div class="card-section"><a onClick="__gaTracker('send','event','Recirculating Content','Click',' Post Block');" class="image" href="https://www.peacearchnews.com/trending-now/whos-afraid-of-friday-the-13th/"><h5 class="active">Who&#8217;s afraid of Friday the 13th?</h5></a><p class="lead show-for-medium">Is friggatriskaidekaphobia harmless fun, or should we be proceeding with caution today?
</p></div></div></div><!-- End - Single Card --><!-- Start - Single Card --><div class="column"><div class='card '><a onClick="__gaTracker('send','event','Recirculating Content','Click',' Post Block');" class="image" href="https://www.peacearchnews.com/news/b-c-mom-backs-mps-calls-for-criminal-probe-of-opioid-manufacturers/"><img src="https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11437948_web1_CPT139468669.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" srcset="https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11437948_web1_CPT139468669.jpg 660w, https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11437948_web1_CPT139468669-300x195.jpg 300w, https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11437948_web1_CPT139468669-640x417.jpg 640w, https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11437948_web1_CPT139468669-300x195@2x.jpg 600w" sizes="(max-width: 1199px) 98vw, 660px" /></a> <div class="card-section"><a onClick="__gaTracker('send','event','Recirculating Content','Click',' Post Block');" class="image" href="https://www.peacearchnews.com/news/b-c-mom-backs-mps-calls-for-criminal-probe-of-opioid-manufacturers/"><h5 class="active">B.C. mom backs MP&#8217;s calls for criminal probe of opioid manufacturers</h5></a><p class="lead show-for-medium">Helen Jennens is supporting a MP’s calls for the federal government to launch a criminal investigation against the manufacturers of opioids 
</p></div></div></div><!-- End - Single Card --><!-- Start - Single Card --><div class="column"><div class='card '><a onClick="__gaTracker('send','event','Recirculating Content','Click',' Post Block');" class="image" href="https://www.peacearchnews.com/news/trudeau-to-talk-nafta-with-mexican-president-u-s-vice-president-while-in-peru/"><img src="https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11437907_web1_180413-CPW-nafta.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" srcset="https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11437907_web1_180413-CPW-nafta.jpg 660w, https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11437907_web1_180413-CPW-nafta-300x200.jpg 300w, https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11437907_web1_180413-CPW-nafta-640x427.jpg 640w, https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11437907_web1_180413-CPW-nafta-300x200@2x.jpg 600w" sizes="(max-width: 1199px) 98vw, 660px" /></a> <div class="card-section"><a onClick="__gaTracker('send','event','Recirculating Content','Click',' Post Block');" class="image" href="https://www.peacearchnews.com/news/trudeau-to-talk-nafta-with-mexican-president-u-s-vice-president-while-in-peru/"><h5 class="active">Trudeau to talk NAFTA with Mexican president, U.S. vice-president while in Peru</h5></a><p class="lead show-for-medium">Trudeau will aim to advance Canada’s position on North American free trade talks when he meets with Mexican President Enrique Pena Nieto 
</p></div></div></div><!-- End - Single Card --><!-- Start - Single Card --><div class="column"><div class='card '><a onClick="__gaTracker('send','event','Recirculating Content','Click',' Post Block');" class="image" href="https://www.peacearchnews.com/news/canadian-home-sales-plunge-22-7-in-march/"><img src="https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11437894_web1_180413-CPW-forsale.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" srcset="https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11437894_web1_180413-CPW-forsale.jpg 660w, https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11437894_web1_180413-CPW-forsale-300x200.jpg 300w, https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11437894_web1_180413-CPW-forsale-640x427.jpg 640w, https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11437894_web1_180413-CPW-forsale-300x200@2x.jpg 600w" sizes="(max-width: 1199px) 98vw, 660px" /></a> <div class="card-section"><a onClick="__gaTracker('send','event','Recirculating Content','Click',' Post Block');" class="image" href="https://www.peacearchnews.com/news/canadian-home-sales-plunge-22-7-in-march/"><h5 class="active">Canadian home sales plunge 22.7% in March</h5></a><p class="lead show-for-medium">March home sales volume plunges 22.7%, national average price down 10.4%: CREA
</p></div></div></div><!-- End - Single Card --><!-- Start - Single Card --><div class="column"><div class='card '><a onClick="__gaTracker('send','event','Recirculating Content','Click',' Post Block');" class="image" href="https://www.peacearchnews.com/news/he-was-a-gift-broncos-stats-keeper-remembered-for-math-memory-kindness/"><img src="https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11437876_web1_180413-CPW-BRONCOS.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" srcset="https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11437876_web1_180413-CPW-BRONCOS.jpg 660w, https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11437876_web1_180413-CPW-BRONCOS-300x201.jpg 300w, https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11437876_web1_180413-CPW-BRONCOS-640x429.jpg 640w, https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11437876_web1_180413-CPW-BRONCOS-300x201@2x.jpg 600w" sizes="(max-width: 1199px) 98vw, 660px" /></a> <div class="card-section"><a onClick="__gaTracker('send','event','Recirculating Content','Click',' Post Block');" class="image" href="https://www.peacearchnews.com/news/he-was-a-gift-broncos-stats-keeper-remembered-for-math-memory-kindness/"><h5 class="active">&#8216;He was a gift:&#8217; Broncos stats keeper remembered for math, memory, kindness</h5></a><p class="lead show-for-medium">Brody Hinz was one of 16 people who have died as a result of the junior hockey team’s bus colliding with a semi truck last week
</p></div></div></div><!-- End - Single Card --></div>            </div>

            <div class="small-12 large-4 module-most-read columns">
                <div class="row">
    <div class="small-12 module-trending story columns">
        <h3 class="text-center">Most Read</h3>
        <ul class="trending-maxi">
                            <li>
                <div id="post-86061" class="row story-list-item collapse">
	<div class="small-12 medium-8 photo content columns">
					<h4 class="count"></h4><h5><a onClick="__gaTracker('send','event','Recirculating Content','Click','News Most Read');" href="https://www.peacearchnews.com/news/video-traffic-concerns-linger-after-surrey-oks-church-townhouse-development-again/">VIDEO: Traffic concerns linger after Surrey OKs church, townhouse development again</a></h5>
				<p class="lead web show-for-medium hide-for-large">Surrey resident shows city council videos of dangerous road conditions along 148th Street
</p>	</div>
			<div class="show-for-medium medium-4 columns">
							<a onClick="__gaTracker('send','event','Recirculating Content','Click','News Most Read');" href="https://www.peacearchnews.com/news/video-traffic-concerns-linger-after-surrey-oks-church-townhouse-development-again/"><img src="https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11429425_web1_180412-SUL-Panorama.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" srcset="https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11429425_web1_180412-SUL-Panorama.jpg 686w, https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11429425_web1_180412-SUL-Panorama-300x200.jpg 300w, https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11429425_web1_180412-SUL-Panorama-640x426.jpg 640w, https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11429425_web1_180412-SUL-Panorama-300x200@2x.jpg 600w" sizes="(max-width: 1199px) 98vw, 686px" /></a>
					</div>
	</div>
            </li>
                            <li>
                <div id="post-85995" class="row story-list-item collapse">
	<div class="small-12 medium-8 photo content columns">
					<h4 class="count"></h4><h5><a onClick="__gaTracker('send','event','Recirculating Content','Click','News Most Read');" href="https://www.peacearchnews.com/news/first-of-its-kind-cat-centre-opens-to-lower-mainland-felines/">First-of-its-kind cat centre opens to Lower Mainland felines</a></h5>
				<p class="lead web show-for-medium hide-for-large">An opening ceremony is underway for a new feline intake facility at Aldergrove’s animal shelter.
</p>	</div>
			<div class="show-for-medium medium-4 columns">
							<a onClick="__gaTracker('send','event','Recirculating Content','Click','News Most Read');" href="https://www.peacearchnews.com/news/first-of-its-kind-cat-centre-opens-to-lower-mainland-felines/"><img src="https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11428971_web1_ISOasis.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" srcset="https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11428971_web1_ISOasis.jpg 1200w, https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11428971_web1_ISOasis-300x200.jpg 300w, https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11428971_web1_ISOasis-1024x683.jpg 1024w, https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11428971_web1_ISOasis-640x427.jpg 640w, https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11428971_web1_ISOasis-300x200@2x.jpg 600w" sizes="(max-width: 1200px) 100vw, 1200px" /></a>
					</div>
	</div>
            </li>
                            <li>
                <div id="post-85976" class="row story-list-item collapse">
	<div class="small-12 medium-8 photo content columns">
					<h4 class="count"></h4><h5><a onClick="__gaTracker('send','event','Recirculating Content','Click','News Most Read');" href="https://www.peacearchnews.com/news/video-surrey-boys-painful-cancer-fight-inspires-call-for-blood-donors/">VIDEO: Surrey boy&#8217;s painful cancer fight inspires call for blood donors</a></h5>
				<p class="lead web show-for-medium hide-for-large">From today to April 22, there are about 2,900 open blood donation appointments to fill in B.C.
</p>	</div>
			<div class="show-for-medium medium-4 columns">
							<a onClick="__gaTracker('send','event','Recirculating Content','Click','News Most Read');" href="https://www.peacearchnews.com/news/video-surrey-boys-painful-cancer-fight-inspires-call-for-blood-donors/"><img src="https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11406629_web1_180412-SUL-Eli.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" srcset="https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11406629_web1_180412-SUL-Eli.jpg 1200w, https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11406629_web1_180412-SUL-Eli-300x200.jpg 300w, https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11406629_web1_180412-SUL-Eli-1024x683.jpg 1024w, https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11406629_web1_180412-SUL-Eli-640x427.jpg 640w, https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11406629_web1_180412-SUL-Eli-300x200@2x.jpg 600w" sizes="(max-width: 1200px) 100vw, 1200px" /></a>
					</div>
	</div>
            </li>
                            <li>
                <div id="post-85984" class="row story-list-item collapse">
	<div class="small-12 medium-8 photo content columns">
					<h4 class="count"></h4><h5><a onClick="__gaTracker('send','event','Recirculating Content','Click','News Most Read');" href="https://www.peacearchnews.com/news/mother-of-slain-b-c-sisters-set-to-run-half-marathon-in-their-honour/">Mother of slain B.C. sisters to run half marathon in their honour</a></h5>
				<p class="lead web show-for-medium hide-for-large">‘I know that they will be running alongside us in spirit’
</p>	</div>
			<div class="show-for-medium medium-4 columns">
							<a onClick="__gaTracker('send','event','Recirculating Content','Click','News Most Read');" href="https://www.peacearchnews.com/news/mother-of-slain-b-c-sisters-set-to-run-half-marathon-in-their-honour/"><img src="https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11425765_web1_chloeaubrey.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" srcset="https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11425765_web1_chloeaubrey.jpg 1200w, https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11425765_web1_chloeaubrey-300x200.jpg 300w, https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11425765_web1_chloeaubrey-1024x683.jpg 1024w, https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11425765_web1_chloeaubrey-640x427.jpg 640w, https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11425765_web1_chloeaubrey-300x200@2x.jpg 600w" sizes="(max-width: 1200px) 100vw, 1200px" /></a>
					</div>
	</div>
            </li>
                            <li>
                <div id="post-86066" class="row story-list-item collapse">
	<div class="small-12 medium-8 photo content columns">
					<h4 class="count"></h4><h5><a onClick="__gaTracker('send','event','Recirculating Content','Click','News Most Read');" href="https://www.peacearchnews.com/news/white-rock-woman-appeals-for-return-of-stolen-e-bike/">White Rock woman appeals for return of stolen e-bike</a></h5>
				<p class="lead web show-for-medium hide-for-large">Police say crime always increases as the weather warms
</p>	</div>
			<div class="show-for-medium medium-4 columns">
							<a onClick="__gaTracker('send','event','Recirculating Content','Click','News Most Read');" href="https://www.peacearchnews.com/news/white-rock-woman-appeals-for-return-of-stolen-e-bike/"><img src="https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11421234_web1_170525-RDA-M-RCMP-car.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" srcset="https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11421234_web1_170525-RDA-M-RCMP-car.jpg 1200w, https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11421234_web1_170525-RDA-M-RCMP-car-300x200.jpg 300w, https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11421234_web1_170525-RDA-M-RCMP-car-1024x683.jpg 1024w, https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11421234_web1_170525-RDA-M-RCMP-car-640x427.jpg 640w, https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11421234_web1_170525-RDA-M-RCMP-car-300x200@2x.jpg 600w" sizes="(max-width: 1200px) 100vw, 1200px" /></a>
					</div>
	</div>
            </li>
                            <li>
                <div id="post-86070" class="row story-list-item collapse">
	<div class="small-12 medium-8 photo content columns">
					<h4 class="count"></h4><h5><a onClick="__gaTracker('send','event','Recirculating Content','Click','News Most Read');" href="https://www.peacearchnews.com/news/rcmp-on-scene-at-176-street-and-no-10-highway/">UPDATE: Highway 10 incident cleared, truck and trailer towed</a></h5>
				<p class="lead web show-for-medium hide-for-large">Nearby worker says he saw gun seized by officers
</p>	</div>
			<div class="show-for-medium medium-4 columns">
							<a onClick="__gaTracker('send','event','Recirculating Content','Click','News Most Read');" href="https://www.peacearchnews.com/news/rcmp-on-scene-at-176-street-and-no-10-highway/"><img src="https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11433069_web1_180418-CLR-Hwy10PoliceIncident_2.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" srcset="https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11433069_web1_180418-CLR-Hwy10PoliceIncident_2.jpg 1200w, https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11433069_web1_180418-CLR-Hwy10PoliceIncident_2-300x200.jpg 300w, https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11433069_web1_180418-CLR-Hwy10PoliceIncident_2-1024x683.jpg 1024w, https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11433069_web1_180418-CLR-Hwy10PoliceIncident_2-640x427.jpg 640w, https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11433069_web1_180418-CLR-Hwy10PoliceIncident_2-300x200@2x.jpg 600w" sizes="(max-width: 1200px) 100vw, 1200px" /></a>
					</div>
	</div>
            </li>
                            <li>
                <div id="post-86059" class="row story-list-item collapse">
	<div class="small-12 medium-8 photo content columns">
					<h4 class="count"></h4><h5><a onClick="__gaTracker('send','event','Recirculating Content','Click','News Most Read');" href="https://www.peacearchnews.com/news/b-c-police-officer-dies-after-30-years-in-a-coma/">B.C. police officer dies after 30 years in a coma</a></h5>
				<p class="lead web show-for-medium hide-for-large">Injuries sustained while on-duty left Victoria officer in a coma until his death Wednesday
</p>	</div>
			<div class="show-for-medium medium-4 columns">
							<a onClick="__gaTracker('send','event','Recirculating Content','Click','News Most Read');" href="https://www.peacearchnews.com/news/b-c-police-officer-dies-after-30-years-in-a-coma/"><img src="https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11432300_web1_VNE-ConstIanJordan.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" srcset="https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11432300_web1_VNE-ConstIanJordan.jpg 1200w, https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11432300_web1_VNE-ConstIanJordan-300x200.jpg 300w, https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11432300_web1_VNE-ConstIanJordan-1024x683.jpg 1024w, https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11432300_web1_VNE-ConstIanJordan-640x427.jpg 640w, https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/uploads/2018/04/11432300_web1_VNE-ConstIanJordan-300x200@2x.jpg 600w" sizes="(max-width: 1200px) 100vw, 1200px" /></a>
					</div>
	</div>
            </li>
                </ul>
    </div>
</div>            </div>
        </div>
    </div>
</div>

<!-- [post-block post_type='post' taxonomy='category' tax_term='home' taxonomy_posts_per_page='5' taxonomy_2='category' tax_2_term='home2' taxonomy_2_posts_per_page='8' tax_operator='AND' post_template='story-recirc' current_story_id='$currentID' reverse_chron='$reverse_chron'] -->

        </section>
        <div id="footer-container">
            <footer id="footer">
                
                
<div id="bp-logo" class="row">

    <div class="small-12 columns">
 
    <!-- *** BEGIN LOGO *** -->
        <div class="textwidget">
            <a class="pub-logo-small day-6" href="https://www.peacearchnews.com/"><svg id="Outline" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 409.98 51.81"><defs><style>.cls-1{fill:#231f20;}</style></defs><title></title><path class="bp-pub-logo" d="M52.16,2h9.1C71.56,2,76.95,6.12,76.95,16.91c0,9-3.5,15-12,15H61.27v20h-9.1Zm9.17,22.61h.77c3.71,0,5.74-1.47,5.74-7.49C67.85,9.9,65,9.69,62,9.69h-.7Z" transform="translate(-52.16 -1.01)"/><path class="bp-pub-logo" d="M80.79,2h20.58v7.7H89.89V22.44h8.47v8.12H89.89V44.14h12v7.7H80.79Z" transform="translate(-52.16 -1.01)"/><path class="bp-pub-logo" d="M111.31,2h13.16l6.16,49.85h-8.75l-1.33-11.06H113.2l-1.26,11.06h-7.63Zm5.81,7.7H117l-2.87,23.8h5.67Z" transform="translate(-52.16 -1.01)"/><path class="bp-pub-logo" d="M150.65,20.06c0-8.26-1.05-11.34-3.29-11.34-1.89,0-3.78,1.26-3.78,18.2,0,16.38,1,18.2,3.78,18.2,3,0,3.71-4.62,3.85-11.83l7.7.35c0,8.68-1.26,19.18-11.9,19.18-9.73,0-13-9.52-13-25.9,0-19,5.74-25.9,13-25.9,10.5,0,11.76,9.66,11.76,18.76Z" transform="translate(-52.16 -1.01)"/><path class="bp-pub-logo" d="M165.28,2h20.58v7.7H174.38V22.44h8.47v8.12h-8.47V44.14h12v7.7H165.28Z" transform="translate(-52.16 -1.01)"/><path class="bp-pub-logo" d="M210.78,2h13.16l6.16,49.85h-8.75L220,40.78h-7.35l-1.26,11.06h-7.63Zm5.81,7.7h-.14l-2.87,23.8h5.67Z" transform="translate(-52.16 -1.01)"/><path class="bp-pub-logo" d="M234.86,2h10.22c8.68,0,14.42,3.64,14.42,14.14,0,4.2-1.26,9.8-5.32,12.18l5.39,23.52H250.4l-4.27-21.42H244V51.84h-9.1ZM244,23.14h1.82c3.36,0,4.62-3.36,4.62-6.93,0-5.39-2-6.93-5-6.93H244Z" transform="translate(-52.16 -1.01)"/><path class="bp-pub-logo" d="M280,20.06c0-8.26-1.05-11.34-3.29-11.34-1.89,0-3.78,1.26-3.78,18.2,0,16.38,1,18.2,3.78,18.2,3,0,3.71-4.62,3.85-11.83l7.7.35c0,8.68-1.26,19.18-11.9,19.18-9.73,0-13-9.52-13-25.9,0-19,5.74-25.9,13-25.9,10.5,0,11.76,9.66,11.76,18.76Z" transform="translate(-52.16 -1.01)"/><path class="bp-pub-logo" d="M294.64,2h9.1V22h5.74V2h9.1V51.84h-9.1V30.7h-5.74V51.84h-9.1Z" transform="translate(-52.16 -1.01)"/><path class="bp-pub-logo" d="M340.49,2h8.89l8.33,26.32h.14V2h7.28V51.84h-7.07l-9.73-30.17h-.14V51.84h-7.7Z" transform="translate(-52.16 -1.01)"/><path class="bp-pub-logo" d="M372.06,2h20.58v7.7H381.16V22.44h8.47v8.12h-8.47V44.14h12v7.7H372.06Z" transform="translate(-52.16 -1.01)"/><path class="bp-pub-logo" d="M396.84,2h8.26l3.22,29.26h.14L412.8,2H421l4,29.26h.14L428.69,2h6.51l-6.51,49.85h-8.26l-4.34-31.57h-.14l-4.48,31.57h-8Z" transform="translate(-52.16 -1.01)"/><path class="bp-pub-logo" d="M446,37.42c0,2.8,0,7.7,3.92,7.7,3,0,4.06-2.8,4.06-4.83,0-8.89-16.52-10.92-16.52-25.69C437.51,7.1,441.57,1,449.27,1c8.19,0,11.34,6.23,11.55,15.19H452.7c0-2.8,0-7.49-3.64-7.49-2.17,0-3.43,1.82-3.43,4.55,0,8.47,16.52,11.34,16.52,25.83,0,7.63-4.34,13.72-12.53,13.72-9.73,0-11.69-8.54-11.69-15.4Z" transform="translate(-52.16 -1.01)"/></svg></a>        </div>

    <!-- *** END LOGO *** -->
    </div>            
        
</div><!-- row -->

<div id="bp-social-footer" class="row">
    <div class="small-12 columns">
                    
        <div class="textwidget">
            <ul class="social footer">
	<li><a title="Follow us on Facebook" class="social fa fa-facebook-f" href="https://www.facebook.com/peacearchnews" target="_blank"></a></li>
	<li><a title="Follow us on Twitter" class="social fa fa-twitter" href="https://twitter.com/PeaceArchNews" target="_blank"></a></li>
<!-- 	<li><a title="Follow us on Instagram" class="social fa fa-instagram" href="#"  target="_blank"></a></li>
	<li><a title="RSS Feed" class="social fa fa-rss" href="/feed/"></a></li> -->
<li><a title="Submit a story" href="/submit/">
            <img style="margin-bottom:0;width: 34px;height: 34px;" 
            src="https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/themes/BlackPress/assets/images/submit.png"></a>
            </li></ul>        </div>

    </div>
</div><!-- row -->

<div id="bp-site-map-title" class="row" >
    <div class="small-12 columns" >
                
        <div class="textwidget" >        
             <h4 class="text-center">Explore Peace Arch News</h4>
        </div>

    </div>
</div><!-- row -->   

<!-- <div id="bp-site-map" class="row" > -->
<div id="bp-site-map" class="small-12 column row" >
    <!-- <div class="small-12 columns"> -->

        <ul><li><a href="/news/">NEWS</a></li><li><a href="/sports/">SPORTS</a></li><li><a href="/trending-now/">TRENDING NOW</a></li><li><a href="/business/">BUSINESS</a></li><li><a href="/entertainment/">ENTERTAINMENT</a></li><li><a href="/life/">LIFE</a></li><li><a href="/community/">COMMUNITY</a></li><li><a href="/opinion/">OPINION</a></li><li><a href="/video/">VIDEOS</a></li><li><a href="/weather/">WEATHER</a></li><li><a href="/obituaries/">OBITUARIES</a></li><li><a href="/e-editions/">SPECIAL SECTIONS</a></li><li><a href="/marketplace/">MARKETPLACE</a></li><li><a href="/contests/">CONTESTS</a></li><li><a href="/contact-us/">CONTACT US</a></li></ul>                             

    <!-- </div>  -->                        
</div><!-- row -->

<div id="bp-media-group" class="row" >
    
    <div class="small-12 columns">
                
        <div class="textwidget">
            
            <a href="//www.blackpress.ca/publications/">BLACK PRESS MEDIA</a>      
           
        </div>

    </div>
    
    <div class="small-12 columns menu-footer-container">
        <ul id="menu-footer" class="menu" >
            
                     
                    
                    <li class="menu-item" >
                        <a  target="_blank" href="//www.surreynowleader.com">Surrey Now Leader</a>
                    </li>
                
                     
                    
                    <li class="menu-item" >
                        <a  target="_blank" href="//www.langleytimes.com">Langley Times</a>
                    </li>
                
                     
                    
                    <li class="menu-item" >
                        <a  target="_blank" href="//www.langleyadvance.com">Langley Advance</a>
                    </li>
                
                     
                    
                    <li class="menu-item" >
                        <a  target="_blank" href="//www.mapleridgenews.com">Maple Ridge-Pitt Meadows News</a>
                    </li>
                
                     
                    
                    <li class="menu-item" >
                        <a  target="_blank" href="//www.cloverdalereporter.com">Cloverdale Reporter</a>
                    </li>
                
                     
                    
                    <li class="menu-item" >
                        <a  target="_blank" href="//www.northdeltareporter.com">North Delta Reporter</a>
                    </li>
                
                    
        
        </ul>
        
    </div>

</div><!-- row -->

<div id="bp-terms" class="row" >
    
    <div class="small-12 columns">
        
        <ul id="menu-footer" class="menu">
            
            <li class="menu-item"><a target="_blank"href="https://www.peacearchnews.com/contact-us/">Contact Us</a></li><li class="menu-item"><a target="_blank"href="https://www.peacearchnews.com/our-team/">Our Team</a></li><li class="menu-item"><a target="_blank"href="https://www.peacearchnews.com/privacy-policy/">Privacy Policy</a></li><li class="menu-item"><a target="_blank"href="https://www.peacearchnews.com/terms-of-use/">Terms of use</a></li><li class="menu-item"><a target="_blank"href="https://www.peacearchnews.com/weather/">White Rock Weather</a></li><li class="menu-item"><a target="_blank"href="https://www.peacearchnews.com/./local-news/">White Rock News</a></li><li class="menu-item"><a target="_blank"href="http://bcclassifieds.com/">White Rock Classifieds</a></li>      
        </ul>

    </div>

    <div class="small-12 columns">
                
        <div class="textwidget">
            &copy; 2018, <a href="#"></a>Peace Arch News and <a href="http://www.blackpress.ca/">Black Press Group Ltd.</a>
        </div>

    </div>

</div><!-- row -->

                            </footer>
        </div>

        


                    <style type="text/css"> 
                                        
                        div.aw-widget-current [class*="bg-"] {
                            background: none !important;
                        }

                        div.aw-current-weather-inner h3 {
                            display: none;
                        }

                        div.aw-widget-current-inner div.aw-widget-content {
                            border: none !important;
                        }

                        div.aw-widget-current-inner div.aw-widget-content.bg-cl, 
                        div.aw-widget-current-inner div.aw-widget-content.bg-cl a.aw-current-weather, 
                        div.aw-widget-current-inner div.aw-widget-content.bg-s, 
                        div.aw-widget-current-inner div.aw-widget-content.bg-s a.aw-current-weather {
                                color: #000 !important;
                        }

                        div.aw-widget-current-inner div.aw-widget-content a.aw-current-weather p span.aw-temperature-today b {
                            font-weight: 600 !important;
                            padding-left: 40px !important;
                            font-size: 1.5rem !important;
                        }

                        div.aw-widget-current-inner div.aw-widget-content a.aw-current-weather p time {
                            display: none !important;
                        }

                        div.aw-widget-current-inner div.aw-widget-content a.aw-current-weather p span.aw-weather-description {
                            display: none !important;
                        }
                        
                        div.aw-widget-current-inner a.aw-toggle {
                            display: none !important;
                        }

                        div#weatherContainer {
                            padding-top: 10px;
                        }

                        .lt-106 div.aw-widget-current-inner div.aw-widget-content a.aw-current-weather span.aw-icon {
                            background-position: 0 0 !important;
                        }

                        .lt-115 div.aw-widget-current-inner div.aw-widget-content a.aw-current-weather span.aw-icon {
                            z-index: 1 !important;
                        }

                        .lt-479 div.aw-widget-current-inner div.aw-widget-content a.aw-current-weather p {
                            z-index: 1 !important;
                        }

                        @media screen and (max-width: 39.9375em) {
                            div.aw-widget-current-inner div.aw-widget-content a.aw-current-weather {
                                color: #fff !important;
                            }

                            div#weatherContainer {
                                padding-top: 10px;
                            }

                            div.aw-widget-current-inner div.aw-widget-content.bg-cl, 
                            div.aw-widget-current-inner div.aw-widget-content.bg-cl a.aw-current-weather, 
                            div.aw-widget-current-inner div.aw-widget-content.bg-s, 
                            div.aw-widget-current-inner div.aw-widget-content.bg-s a.aw-current-weather {
                                color: #fff !important;
                            }

                        }
                    </style>
                <!-- Start Catfish ad -->
<div style="position:fixed;bottom:0px;width:100%;background:white;">
<div class='code-block code-block-17' style='margin: 8px 0; clear: both;'>
<!-- Reserved for Catfish ad. See display call in Footer. -->
<div id="div-gpt-17" class="gpt-ad" style="margin: 0 auto;width:320px;">
<script type='text/javascript'>
    googletag.cmd.push(function() {googletag.display('div-gpt-17');gptRefreshSlots.push(17);});
</script>
</div></div>
</div>
<!-- End Catfish ad -->


<!-- Start Interstitial ad -->
<div id='page-cover' style="z-index:999999; text-align:center;background-color:#FFF; position:fixed; top:0; left:0; width:100%; height:100%;padding-top: 25%;padding-left: 10px;padding-right: 10px;display: none;">
<div class='code-block code-block-18' style='margin: 8px 0; clear: both;'>
<!-- Reserved for Interstitial ad. See display call in Footer. -->
<div id="div-gpt-18" class="gpt-ad">
<script type='text/javascript'>
  googletag.cmd.push(function() { googletag.display('div-gpt-18');gptRefreshSlots.push(18);googletag.pubads().addEventListener('slotRenderEnded', function(event) {
                if (event.slot === gptAdSlots[18]) {
                    if(event.isEmpty) {
                        document.getElementById("page-cover").style.display = 'none';
                    }
                    else{
                        console.log("setting timer")
                    	//delay modal window from opening to allow ad tags to render; the above listener means the tags loaded, not necessarily showing the creative.
                    	var delayModal = window.setTimeout(
                    		function(){var timeoutID = window.setTimeout(function(){document.getElementById("page-cover").style.display = 'none';},8000);document.getElementById("page-cover").style.display = 'block';}
                    	,5000);
                    }
                }
            });
  });
  $(document).ready(function() {
    	$("#close-interstitial").click(function() {
        	document.getElementById("page-cover").style.display = 'none';
    	});
	}); 
</script>
</div>
<div><a id="close-interstitial" href="#">Close ad</a></div></div>
</div>
<!-- End Interstitial ad -->

l -->
<!-- /1036919/vendor_library_0 -->
<div id='div-gpt-21' style='height:1px; width:1px;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-21');gptRefreshSlots.push(21); });
</script>
</div>
<!-- End vendor library call -->
<script type='text/javascript'>
    googletag.cmd.push(function() {
        for (i = 0; i < gptAdSlots.length; i++) { 
            if(gptRefreshSlots.indexOf(i) == -1){                
                googletag.destroySlots([gptAdSlots[i]]);
                console.log('destroyed ' + i);
            }
        }
        googletag.pubads().refresh(gptAdSlots);
    });
</script><script type='text/javascript' src='//content.jwplatform.com/libraries/22ZiKJyA.js?ver=1.0.0'></script>
<script type='text/javascript' src='https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/themes/BlackPress/assets/components/featherlight/featherlight.js?ver=1.6.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var foundation = {"is_front_page":"0"};
/* ]]> */
</script>
<script type='text/javascript' src='https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/themes/BlackPress/dest/javascript/foundation.min.js?ver=2.20.0'></script>
<script type='text/javascript' src='https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/themes/BlackPress/dest/javascript/what-input/what-input.min.js?ver=4.0.3'></script>
<script type='text/javascript' src='https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-content/themes/BlackPress/dest/javascript/frame_resize_2.0.min.js?ver=2.20.0'></script>
<script type='text/javascript' src='https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-includes/js/comment-reply.min.js?ver=4.9.5'></script>
<script type='text/javascript' src='https://ow0hs2zhmkp2497op3xhvxsa-wpengine.netdna-ssl.com/wp-includes/js/wp-embed.min.js?ver=4.9.5'></script>


</body>
</html>
